TLS Retirement

Dear Merchant,

This message is to advise you that Moneris Solutions Corporation (“Moneris”) is discontinuing support for the 3DES cipher algorithm on March 20, 2017. The 3DES cipher algorithm is no longer the most secure option available in market and newer, more secure ciphers are supported through current generation Web browsers.

Moneris has also extended the end of support date for TLS 1.0 from January 29th, 2018 to March 20th, 2018. To avoid business disruption and potential security threats, you are required to update your production environments to the latest internet browser(s), which are equipped with compatible, industry compliant ciphers (other than 3DES) and support TLS 1.1 and TLS 1.2. Moneris recommends the following browser versions as a minimum requirement:

  • Internet Explorer 11
  • Google Chrome 30 or higher
  • Mozilla Firefox 27 or higher
  • Safari 8 or higher

Businesses attempting to connect to Moneris Gateway payment production servers using 3DES cipher will be denied access on March 20, 2017.

For tips on how to enable TLS 1.2, please take a moment to read Moneris’ PCI Compliance & TLS 1.0 Retirement (http://community.moneris.com/blogs/b/announcements/posts/pci-compliance-amp-tls-1-0-retirement)  blog. If you have any questions, please do not hesitate to contact us at onlinepayments@moneris.com or 1-866-562-4354.

Sincerely,
eProduct Support
Moneris